Netpd 2.3.0 release

Hi

netpd 2.3.0 is released.

This release features also stand-alone applications for macOS and Windows.

Features and changes:

  • give chat and unpatch a facelift
  • load instruments from scroll list instead of openpanel
  • support unlimited nesting of dynamic loading with new abstraction
    [netpd-bus-order]. This allows effects to load other effects into
    themselves
  • restore support for loading from old text-based preset file format
  • broadcast loading from preset file to all clients for improved consistency
  • add debug message printing facility (prints incoming and/or outgoing OSC
    messages)
  • add support for IRC style /commands in chat (check with ‘/help’)
  • add protected mode for unpatch. Protects from interactions with
    peers while developing instruments
  • refactor lots of internal stuff:
    • use $1.NETPD bus for everything in netpd_* abstractions
    • remove second number argument to [netpd-dump]. Use new [netpd-bus-order]
      to enforce order of state dumps.
    • only initialize instrument when necessary (e.g. not when receiving
      state from peer or from preset file)
    • only search for sync peer when necessary

New instruments since last release:

  • ripple: sample-based synthesis similar to soundfonts
  • ep-mk2: physical model of an e-piano (port of Mike Moreno’s ep-mk2)
  • filtlib: finally a suite of filters (based on mmb)

https://www.netpd.org/download

https://untalk.netpd.org/

Have fun!
Roman

1 Like

Thanks!
This works pretty well for me but I’m having a bit of trouble loading old sets - some of the simpler ones open up ok but lots of them make Pd crash and close. Maybe there are some of my homegrown instruments that are causing a problem but I’m not sure that all the sets that crash include them.

Thanks for your feedback.

I’m afraid I won’t be able to really fix crashes, as the crashes either happen in Pd or in an external. Maybe we can narrow down the source of the crash and sometimes it is possible to work-around a specific condition that trigger crashes.

Can you share a set that reliably triggers a crash? And can you specify your setup, OS, Pd Version, netpd as app or Pd and netpd installed separately?

What you could try - in case you want to investigate some more on your own - is the rename the instruments used in the crashing set one after the other so that unpatch won’t find it and load the set. If the crash doesn’t happen anymore, you know which instrument is “responsible”.

just tried a few variations going back and forth between netpd 2.2 (where the sets still load ok) and 2.3. It seems I can fix a set by taking out ‘dynlib’ and more specifically ‘rcomp’ but i haven’t yet seen whether this is always the cause of the problem.

I thought I might as well share a few of the sets I have kicking around…

the one I used for testing was ‘mybloodytribalthing’ - it crashes 2.3 but works if I remove ‘rcomp’.

setup:
Pd 0.51
MacOs 10.13
netpd installed separately

actually it still crashes even with rcomp removed.
I’ve tried a few further steps…
-reinstalled all the externals
-put all the old versions of netpd out of the way so they can’t cause any confusion
-now just building simple setups in 2.3.0 and saving them then reloading them directly - lots of crashes…

Hm… i can’t reproduce on my Linux box.

Can you specify a set of yours that crashes almost reliably? All the ones I tried do not crash here. If I have a set that crashes, I can at least look with gnu debugger where the crash occurs.

I’m not sure if that’s helpful at all, but you can print all the messages received to the Pd console. Enter

/debug from on

into chat. Messages are printed right before they are executed. If always the same message is the last before the crash with a certain set, then this might give you hint which instrument causes the crash.

Loading your sets is actually so much fun and really interesting for me and it saddens me that we cannot talk about those without the technical issues in our neck.

Does the netpd.app crash in the same way?

I’m running it on macOS 10.15 and I actually found a set that occasionally crashes: guitarscape. But most sets don’t.

ah… think i’ve got closer to working it out - if i connect to the netpd server and then load sets it works for all of them! so i guess there is something in the new netpd version that does something with the server as a saved patch is loaded and it breaks when netpd is offline.

glad you are enjoying my weird archive!

Oh, i see. I always tried to load them while online. I believe this can be fixed.

@beem Can you test if it has been fixed? https://www.netpd.org/~roman/netpd-plus-instruments.zip

That works fine! thanks!